Systems are slow

Incident Report for Schools Portal

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 17:34 UTC

Update

We are continuing to investigate this issue.
Posted Aug 13, 2025 - 17:26 UTC

Update

We have identified the systems are slow at this time 1.23 PM. We are working on identifying the issue
Posted Aug 13, 2025 - 17:23 UTC

Investigating

We are currently investigating this issue.
Posted Aug 13, 2025 - 17:22 UTC
This incident affected: Parent App and Pikmykid School Portals.